[KBA-01359] Security Center cannot connect to the Directory database because it is in Single User mode - Security Center 5.4 - 5.9

series
Security Center 5.4 - 5.9
revised_modified
2020-08-26

[KBA-01359] Security Center cannot connect to the Directory database because it is in Single User mode

This article explains how to switch the Directory database from Single User mode to Multi User mode to get Security Center to connect to it.

Symptoms

In Server Admin, a newly created Directory database shows the following message:

Database not connected

In SQL Server Management Studio, it shows that the Directory database is set to Single User mode.

Restarting the Directory role, SQL, or the Genetecâ„¢ Server service does not fix the issue.

Cause

The Directory database must be in Multi User mode so that Security Center can be connected to it. During the database creation process, the Directory is set to Single User mode to ensure it is not tampered with. After the database is created, a script switches the Directory to Multi User mode. Occasionally, the script might not switch the user mode properly.

Workaround

To fix the issue, create a Directory database by overwriting the existing one.
CAUTION:
Performing this procedure deletes existing database information; however, you should not lose any data because new databases are typically empty.
  1. Stop the Genetecâ„¢ services.
  2. In Server Admin, create a Directory database.

  3. Select the Overwrite existing database option to replace the faulty database with a functional one.