Wenn die Incident Manager-Rolle in Config Tool offline geschaltet wird, weil keine Verbindung zum RabbitMQ-Dienst hergestellt werden kann, können Sie das Problem beheben, indem Sie einige relevante Einstellungen wie Firewall-Ports, Benutzeranmeldedaten usw. überprüfen.
Symptome
Die Incident Manager-Rolle in Config Tool ist rot, und wenn Sie auf klicken, wird folgende Fehlermeldung angezeigt: RabbitMQ-Verbindung fehlgeschlagen - <server IP address> Wird in x Sekunden wiederholt
Ursache
Der Server, auf dem die Incident Manager-Rolle ausgeführt wird, kann über eine SSL-Verbindung keine Verbindung zum RabbitMQ-Dienst auf Port 5671 (Standardport) herstellen.
Lösung
Probieren Sie eine oder mehrere der folgenden Lösungen aus:
- Rufen Sie in Windows auf und prüfen Sie, ob der RabbitMQ-Dienst auf dem Server, auf dem er installiert ist, erfolgreich gestartet wurde.
- Prüfen Sie auf den Registerkarten für die Incident Manager-Rollenkonfiguration in Config Tool, ob Sie den richtigen Benutzernamen und das richtige Kennwort für die RabbitMQ-Verbindung verwenden. Der Benutzername und das Kennwort wurden während der Genetec Mission Control™-Installation erstellt.
- Ersetzen Sie den RabbitMQ-Servernamen durch die IP-Adresse des Servers, oder stellen Sie sicher, dass der Servername eindeutig ist. Die folgende Abbildung zeigt ein Beispiel für den RabbitMQ-Anmeldebildschirm:
- Prüfen Sie, ob der Server, auf dem die Incident Manager-Rolle ausgeführt wird, über Port 5671 auf den Server zugreifen kann, auf dem RabbitMQ ausgeführt wird.TIPP: Öffnen Sie die Eingabeaufforderung und geben Sie Folgendes ein:
Telnet <server IP address> 5671
Wenn die Server ordnungsgemäß kommunizieren, erhalten Sie eine Antwort. - Prüfen Sie, ob alle Firewall-Ports TCP-Verbindungen in beide Richtungen zwischen dem Genetec Mission Control™-Server und dem RabbitMQ-Server an Port 5671 zulassen.