Wenn Sie das Kennwort für das RabbitMQ-Konto verlieren, das während der Genetec Mission Control™-Installation erstellt wurde, können Sie das Kennwort an der RabbitMQ-Eingabeaufforderung ändern.
Symptome
Die Incident Manager-Rolle in Config Tool ist rot.
Ursache
Ohne gültige RabbitMQ-Anmeldeinformationen können Sie über Config Tool keine Verbindung zum RabbitMQ-Dienst herstellen. Ohne eine Verbindung herzustellen, wird die Incident Manager-Rolle offline geschaltet und wird rot.
Lösung
So setzen Sie das Kennwort für Ihr RabbitMQ-Konto zurück:
- Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten in Windows:
- Geben Sie im Windows-Suchfeld cmd ein.
- Drücken Sie die Tastenkombination Strg+Shift+Eingabe.
Das Fenster Benutzerkontensteuerung wird geöffnet und fordert Sie zur Ausführung als Administrator auf.
- Klicken Sie auf Ja.
- Navigieren Sie zum RabbitMQ-Ordner sbin. BEMERKUNG: Er befindet sich normalerweise unter C:\Programme\RabbitMQ Server\rabbitmq_server-xyz\sbin.
- Führen Sie den folgenden Befehl aus, um die aktuelle Benutzerliste in RabbitMQ anzuzeigen:
rabbitmqctl list_users
- Setzen Sie das Passwort Ihres RabbitMQ-Kontos zurück, indem Sie den folgenden Befehl ausführen:
rabbitmqctl change_password <user> <new password>
BEMERKUNG: Wenn ein Erlang-Cookie-Authentifizierungsfehler die Ausführung der rabbitmqctl-Befehle verhindert, müssen Sie die .erlang.cookie-Dateien auf Ihrem Computer synchronisieren. Weitere Informationen finden Sie in den RabbitMQ-Installationsanweisungen. - Aktualisieren Sie die RabbitMQ-Anmeldeinformationen in Config Tool unter .