Plugin cannot connect to the CCURE 9000 server - CCURE Access Control 3.8.0

CCURE 9000 Access Control Plugin Guide 3.8.0

Product
CCURE 9000 Access Control
Content type
Guides > Plugin and extension guides
Version
3.8
Release
3.8.0
Language
English
Last updated
2023-10-10

If the plugin cannot connect to the CCURE 9000 server, verify that the IP address and port properties are properly set.

Symptom

When the plugin role cannot connect to the CCURE 9000 server, it turns yellow and reports a connection error message in the Diagnostics window.

Causes

Connection issues can occur for the following reasons:
  • The IP address configured for the plugin role is incorrect.
  • The port configured on the plugin role does not match the port configured on the proxy service.
  • Your network devices are configured to block the port.
  • The required services are not running.

Solutions

  • In the Properties page of the plugin role, ensure that the Server and Port fields are set with the correct values.
  • If you get an error message indicating that the port on the proxy side is already used:
    1. Change the port number to a value that is not used.
    2. Make sure to change the port number used on the CCURE 9000 server to match the one configured in the plugin.
  • Use the ping command to verify that the IP address of the CCURE 9000 server is reachable from the plugin role server.
  • Make sure that the routers and switches on your network are not blocking the communications port.
  • Make sure that the proxy service is running on the CCURE 9000 server.
  • Make sure that the Tyco services and applications are running on the CCURE 9000 server.