Troubleshooting: Plugin cannot connect to the CCURE 9000 server - CCURE 3.7

CCURE Access Control Plugin Guide 3.7.0

Applies to
CCURE 3.7
Last updated
2021-10-28
Content type
Guides > Plugin and extension guides
Language
English (United States)
Product
CCURE
Version
3.7

If the plugin cannot connect to the CCURE 9000 server, verify that the IP address and port properties are properly set.

What you should know

When the plugin role cannot connect to the CCURE 9000 server, it turns yellow and reports a connection error message in the Diagnostics window.
Connection issues can occur for the following reasons:
  • The IP address configured for the plugin role is incorrect.
  • The port configured on the plugin role does not match the port configured on the proxy service.
  • Your network devices are configured to block the port.
  • The required services are not running.

Procedure

  1. From the Config Tool home page, open the Plugins task.
  2. In the Plugins task, click Add an entity (), and select Plugin.
    The plugin creation wizard opens.
  3. Check that the Server and Port fields are set with the correct values.
  4. If you get an error message indicating that the port is already used:
    1. Change the port number to a value that is not used, and then click Apply.
    2. Make sure to change the port number used on the CCURE server to match the one configured in the plugin.
  5. Use the ping command to verify that the IP address of the CCURE 9000 server is reachable from the plugin role server.
  6. Make sure that the routers and switches on your network are not blocking the communications port.
  7. Make sure that the Genetec Security Center CCURE Proxy Service is running on the CCURE 9000 server.
  8. Make sure that the Tyco services and applications are running on the CCURE 9000 server.