Cannot install Genetec Mission Control™ on Streamvault™ appliances
If you have issues installing Genetec Mission Control™ on a Streamvault™ appliance, it might be due to the CylancePROTECT policies on the appliance.
Symptoms
When running the Genetec Mission
Control™ installer on
a Streamvault™ appliance, the following
issues might occur:
- You receive an Access denied or fatal error.
- CylancePROTECT quarantines one or more of the following files:
- Win32OpenSSL_Light-1_0_2g.exe
- otp_win64_21.2.exe
- otp_win32_21.2.exe
Cause
Streamvault™ appliances include the latest CylancePROTECT policies (including the whitelist) during manufacturing. If the policies change later, the updates are automatically applied on all Streamvault™ appliances that are connected to the internet.
If CylancePROTECT is in offline mode or not connected to the internet, the policies are not updated.
Solution
To update the CylancePROTECT policies on the Streamvault™ appliance so that you can
install Genetec Mission
Control™, do one of the following:
- Connect the Streamvault™ appliance to the internet in a DMZ so the CylancePROTECT policies get updated, and then run the Genetec Mission Control™ installer.
- If the errors are due to OpenSSL issues and you cannot connect to the internet:
- Install OpenSSL on another machine. Tip: Default path for file installation is C:\OpenSSL-Win32\bin
- Copy the OpenSSL folder to the Streamvault™ server, and
then run the Genetec Mission
Control™
installer.NOTE: You might still get an error. This will not stop installation.
- Install OpenSSL on another machine.