Supported upgrades from earlier versions of Genetec Mission Control™ - Genetec Mission Control™ 3.1.0.0 | Genetec Mission Control™ Web API 2.7

Genetec Mission Control™ Release Notes 3.1.0.0

Applies to
Genetec Mission Control™ 3.1.0.0 | Genetec Mission Control™ Web API 2.7
Last updated
2022-09-13
Content type
Release notes
Language
English (United States)
Product
Genetec Mission Control™
Version
3.1

Not all earlier versions of Genetec Mission Control™ can upgrade directly to Genetec Mission Control™ 3.1.0.0. Before you upgrade, you must check which upgrade path applies to your current version.

A one-step upgrade is supported for the following Genetec Mission Control™ releases:
  • Genetec Mission Control™ 2.13.4.0 and later.
A two-step upgrade is required for Genetec Mission Control™ releases before 2.13.4.0:
Step 1
Upgrade to Genetec Mission Control™ 2.13.4.0.
Step 2
Upgrade to Genetec Mission Control™ 3.1.0.0.
NOTE: For versions 2.12.0.0 and earlier it is recommended you run Legacy Workflows using Mission Control commands command from the Server Admin:
  1. Click <Your server name>.
  2. Click Actions > Console > Commands > Mission Control commands > Legacy Workflows.
Example: When you have legacy workflows running for active incidents from 2.11 GA the upgrade is blocked.
NOTE: If you have Genetec Mission Control™ Web API installed, it is automatically upgraded to a compatible version when upgrading Genetec Mission Control™.