Incident Manager role not connecting to RabbitMQ - Genetec Mission Control™ 2.12.0.0

Genetec Mission Control™ User Guide 2.12.0.0

Applies to
Genetec Mission Control™ 2.12.0.0
Last updated
2019-07-18
Content type
Guides
Guides > User guides
Language
English (United States)
Product line
Mission Control > Genetec Mission Control™
Version
2.12

If the Incident Manager role in Config Tool goes offline because it cannot connect to the RabbitMQ service, you can resolve the issue by checking a few pertinent settings such as firewall ports, user credentials, and so on.

Symptoms

The Incident Manager role in Config Tool is red, and when you click Maintenance > Diagnose, you receive the following error message: RabbitMQ connection failed - <server IP address> Will retry in x seconds

Cause

The server running the Incident Manager role cannot connect to the RabbitMQ service running on port 5671 (default port) using an SSL connection.

Solution

Try one or a combination of the following solutions:

  • In Windows, go to Control Panel > Services and ensure that the RabbitMQ service has successfully started on the server where it is installed.
  • From the Incident Manager role configuration tabs in Config Tool, ensure that you are using the correct Username and Password for the RabbitMQ connection. The Username and Password would have been created during the Genetec Mission Control™ installation.
  • Replace the RabbitMQ server name with the IP address of the server, or ensure that the server name is clear. The following image shows an example of the RabbitMQ logon screen:
  • Ensure that the server running the Incident Manager role can access the server running RabbitMQ on port 5671.
    Tip: Open the command prompt and enter the following:

    telnet <server IP address> 5671

    If the servers are communicating properly, you will get a response.
  • Ensure that all firewall ports allow TCP connections both ways between the Genetec Mission Control™ server and RabbitMQ server, on port 5671.