Upgrading to Industrial IoT plugin 4.4.2.4 - Industrial IoT 4.4.2.4

Industrial IoT Plugin Guide 4.4.2.4

Applies to
Industrial IoT 4.4.2.4
Last updated
2022-10-12
Content type
Guides > Plugin and extension guides
Language
English
Product
Industrial IoT
Version
4.4

To upgrade your existing Modbus, BACnet, SNMP Manager, or OPC Client plugin, use the Industrial IoT installation package.

Before you begin

  1. Read the release notes to learn about important information for this release.
  2. Confirm that your versions of Security Center and the plugin are compatible.

What you should know

  • Plugin versions later than Industrial IoT 4.3 can be upgraded using the Industrial IoT 4.4 installation package. If you have an earlier version of these products, contact technical support.
  • The plugin must be upgraded on all Security Center client and server computers.
  • An upgrade preserves your current devices and entities and their configuration, and all event notifications.
    NOTE: If you are upgrading from version 4.1 to the current version, you might lose the units that are associated with data points.
  • The plugin database contains all your entities and plugin configuration, such as rules.
  • IMPORTANT: The base license for the BACnet, Modbus, OPC Client, and SNMP Manager have changed. The license now includes 200 data points. If you require more data points, contact your Genetec™ representative.

Procedure

  1. Open Server Admin, and back up the Directory database.
  2. Back up the plugin role database.
  3. Install the new version of the plugin.
  4. Deactivate the plugin role, and then activate it.
    The plugin is ready for use.