Troubleshooting: Plugin installed, but missing from Security Desk and Config Tool - Industrial IoT 5.0.1.1 | BACnet | Modbus | OPC Client | SNMP Manager

Industrial IoT Plugin Guide 5.0.1.1

Applies to
Industrial IoT 5.0.1.1 | BACnet | Modbus | OPC Client | SNMP Manager
Last updated
2023-02-09
Content type
Guides > Plugin and extension guides
Language
English
Product
Industrial IoT
Version
5.0

If the Properties page, reports, events and alarms are missing, then the plugin is not installed on your local machine. The plugin must be installed on a Security Center server (main or expansion) and on all client workstations that are used to monitor events.

Symptoms

  • In Config Tool, you see the plugin in the Plugins task, and you can add a new plugin role, but the role is missing the Properties tab.
  • In Security Desk, you do not see the reports for this plugin.
  • In Security Desk, you are not receiving events or alerts for this plugin.

Causes

  • The plugin is not installed on the local computer.
  • The license (certificate) is invalid.
  • You are missing required user privileges.

Solutions

Solution 1: Install the plugin on your local computer.

Solution 2: Make sure that a Security Center server has the plugin installed, that the plugin role is hosted on it, and that it is configured correctly.

Solution 3: Confirm that the plugin is installed on your Security Center computer: from the home page in Security Desk or Config Tool, click About > Installed components and look in the list for entries that begin with Genetec.Plugins.

Solution 4: Confirm that your system has a license (certificate) for the plugin: from the home page in Security Desk or Config Tool, click About > Certificates, look in the list for the name of the plugin, and make sure that your access permissions are set to Unlimited.