[KBA-79091] Directory and client issues due to large Application table size - This article explains the symptoms in Security Center caused by a large Application table size in the Directory database. - Security Center 5.8.1.2 - 5.8.1.7, 5.9.1.0 - 5.9.4.2, 5.10.0.0

Product
Security Center
Content type
KB articles
Version
5.10
5.9
Language
English
Last updated
2021-10-15

[KBA-79091] Directory and client issues due to large Application table size

This article explains the symptoms in Security Center caused by a large Application table size in the Directory database.

Applies to

Security Center 5.8.1.2 - 5.8.1.7, 5.9.1.0 - 5.9.4.2, 5.10.0.0

Symptoms

Common symptoms are the following:
  • The Directory does not start or takes a long time to start.
  • Two hours after the Directory starts normally, Config Tool or Security Desk freezes when logging on or when executing some actions.
  • The Directory starts using excessive amounts of memory, CPU, or network resources.
  • Roles go offline with a timeout error. The timeout is reported in the Windows Event Viewer logs.

Cause

Due to a coding issue, the cleanup mechanism for the Application table does not work as expected.

To check whether your system is affected, run the following read-only SQL script on your Directory database to view the size of the Application table:
Code
SELECT 
COUNT(1) [Count]
FROM [Application]
WHERE [Type] in (2,22,8,1,11,9,10,5,6,28,7,17,23,24,13,29,25,31)

If the script output lists more than 1, 000 applications, your system might be affected by this issue. For more information, contact Genetecâ„¢ Technical Support.

Workaround

A manual cleanup script is available to address the issue. To acquire the script, contact Genetec Technical Support.

Status

This issue is fixed in the following Security Center versions:
  • 5.8.1.8 and later 5.8 versions
  • 5.9.4.3 and later 5.9 versions
  • 5.10.1.0 and later
We recommend that you run the manual cleanup script after upgrading your system.