Supported HID firmware versions - Security Center 5.7

Security Center Administrator Guide 5.7

Applies to
Security Center 5.7
Last updated
2021-12-16
Content type
Guides > Administrator guides
Language
English (United States)
Product
Security Center
Version
5.7

Genetec Inc. recommends a specific firmware version for each generation of HID controllers, old (Legacy) and new (EVO). Using earlier firmware versions might cause issues with your system.

Security Center works best when the HID controllers are running the recommended certified firmware versions.
Supported firmware Legacy controllers EVO controllers
Recommended certified firmware 2.2.7.568 3.7.0.108
Minimum supported firmware 2.2.7.568 3.5.x

Previously supported firmware versions

To learn about the issues with the previously supported firmware versions, see Limitations in Security Center.

Upgrading HID EVO firmware

To upgrade your HID EVO units from an earlier firmware version (2.3.1.603 or 2.3.1.605 for Edge EVO, and 2.3.1.542 or 2.3.1.673 for VertX EVO) to the recommended firmware version, specific upgrade paths must be followed.