Pre-upgrade checklist for upgrading from an earlier major version of Security Center - Security Center 5.9.4.0

Security Center Installation and Upgrade Guide 5.9.4.0

Applies to
Security Center 5.9.4.0
Last updated
2020-11-05
Content type
Guides
Guides > Installation guides
Language
English (United States)
Product line
Security Center unified platform > Security Center
Version
5.9

To upgrade your Security Center system from an earlier major version to 5.9.4.0, you must go through a series of preparatory steps.

  • A major version is a software version that adds new features, behavioral changes, SDK capabilities, support for new devices, and performance improvements. Using backward compatibility mode, major versions are compatible with up to three previous major versions. A license update is required to upgrade to a new major version. A major version is indicated by a version number with zeros at the third and fourth positions: X.Y.0.0.
  • Different versions of the Security Center clients can coexist on the same machine, but different versions of Security Center Server cannot. Not all current settings are kept if you uninstall your current software version before installing the new one.
  • If the Active Directory role is on a different domain than the Active Directory it is synchronizing with, you must set up a domain trust relationship. For more information on setting up domain trust relationships, see your Microsoft documentation.
Step Task Additional information
Understand prerequisites and key issues
1 Read the release notes for any known issues, limitations, and other information about the release.
2 Review the backward compatibility requirements for Security Center.
3 Make sure you have the following information:
  • The service logon username and password for all your servers.
  • The name of the database server used to manage the Directory database.
 
Prepare
4 Back up your Directory and role-specific databases to a secure location that is separate from your main server.
5 Close all applications related to Microsoft Management Console (MMC), such as Services, Event Viewer, and so on. These applications might lock the Security Center services and prevent them from being updated.
Set up additional software and configuration as needed
6 If you have an Active Directory role in your current system, make sure that the Windows user configured to connect to the Windows Active Directory has Read access to the accountExpires attribute.
CAUTION:
If the Windows user does not have Read access to the accountExpires attribute, all cardholders and credentials previously imported from the Windows Active Directory are deleted the next time you synchronize Security Center with your Windows Active Directory after the upgrade.
When you import users and cardholders to Security Center from a Windows Active Directory, you can set an expiration date for the imported entities by importing the standard attribute accountExpires. The status of the imported entity automatically changes to inactive after the specified date.