Upgrading Security Center 5.6, 5.7, or 5.8 to 5.9 - Security Center 5.9.4.0

Security Center Installation and Upgrade Guide 5.9.4.0

Applies to
Security Center 5.9.4.0
Last updated
2020-11-05
Content type
Guides
Guides > Installation guides
Language
English (United States)
Product line
Security Center unified platform > Security Center
Version
5.9

To have the latest release of Security Center, you can upgrade directly from the previous three major versions to 5.9.

What you should know

Not all tasks and roles work in backward compatibility mode. If you plan to upgrade your system in stages, make sure that the features that are essential to your operation are supported. See Backward compatibility requirements for Security Center.
NOTE: A role is upgraded only if you upgrade the server hosting the role. If you only upgrade the main server, the roles hosted on the expansion servers that are not yet upgraded work in backward compatibility mode.
IMPORTANT: If you upgrade the ALPR Manager, the Archiver it is linked to must also be upgraded. The upgraded ALPR Manager would not work if the Archiver is working in backward compatibility mode.

Procedure

  1. If Omnicastâ„¢ systems were federated to your previous Security Center system, uninstall the Omnicastâ„¢ compatibility packs.
  2. Do one of the following:
  3. Upgrade the rest of your system according to your priorities and schedule.
    If both Security Center Client and Server are installed on the same machine, upgrade them together.
    IMPORTANT: Make sure to note and apply the same settings used for your previous installation: passwords, databases, ports, general properties, and so on.

After you finish

If the file AllowedSynchronizationConfiguration.xml was used to set the synchronization times of your HID VertX units, the settings must be re-applied manually from Config Tool after the upgrade.
Tip: Configure one unit with the required synchronization settings, then use the copy configuration tool to set the same settings on multiple units.