Features that impact an upgrade to Security Center 5.8 GA - Security Center 5.8 GA

Security Center Release Notes 5.8 GA

Applies to
Security Center 5.8 GA
Last updated
2021-08-10
Content type
Release notes
Language
English
Product
Security Center
Version
5.8

It is important to know about Security Center 5.8 features that will change how you interact with the system after an upgrade.

Note the following when upgrading to Security Center 5.8 GA:
Enhanced complexity requirements for main server password
Starting with Security Center 5.8 GA, when you update the main server password used by Server Admin, the new password must meet all of the following criteria:
  • At least 8 characters long
  • 1 or more upper case letters
  • 1 or more lower case letters
  • 1 or more numerical characters
  • 1 or more special characters
  • No spaces or double quotation marks.
New default port for redirectors
Starting with Security Center 5.8 GA, TCP port 960 replaces TCP port 5004 as the initial default port for stream requests.

If you are upgrading from Security Center 5.6 or 5.7, your redirectors will continue to use TCP port 5004 and no action is needed.

If you are upgrading from Security Center 5.5 or earlier, your redirectors will use TCP port 960. Ensure that port 960 is open in addition to port 560 for firewall and network address translation purposes, or you might not be able to view live video streams from remote sites.

Logon dialog box has changed
Starting with Security Center 5.7 SR2, you can no longer leave the Directory field blank in the Logon dialog box. You must enter the name or IP address of the main server you want to connect to. If your client application is running on the main server, you can also enter Localhost as the Directory name.
Custom temporary access rules based on custom fields are deprecated
Temporary access rules are supported natively in Security Center 5.7 SR1 and later. Because custom and native temporary access rules cannot be used together, we recommend that you use our native solution. If you are currently using the custom solution in Security Center 5.6, and want to upgrade to Security Center 5.7 SR1 or later, contact our Technical Assistance Center (GTAC) for help.
New license required for restricted cameras
Starting with Security Center 5.6 GA, there is a new license option called Number of restricted cameras. Cameras developed by some manufacturers have been restricted due to a higher cybersecurity risk profile; these cameras require a special connection license, in addition to the normal camera license. If you have restricted cameras on your system after upgrading to Security Center 5.8, these video units will stop working and the Archiver will be in a warning state until you license the restricted camera connections.

To view a list of manufacturers that require a restricted license, use the Restricted License Type filter on the Supported Device List.

New port required for Archiver roles
Starting with Security Center 5.6 GA, Archivers require two ports: one port for live and playback stream requests (TCP 555) and one port for edge playback stream requests (TCP 605). If you are upgrading from Security Center 5.5 or earlier, make sure that port 605 is open in addition to port 555 for firewall and network address translation purposes, or you might not be able to view playback video streams from edge devices.
Recommendations for running the Global Cardholder Synchronizer (GCS) role
If your system is a sharing guest, make sure of the following:
  • The sharing host system is running the same version, or a later version of Security Center.
  • You have recorded a list of the global partitions you want to synchronize, in case you must apply them after the upgrade.
  • If the GCS role is running on an expansion server, perform one of the following two options:
    • Move the GCS role to the main server hosting the Directory role.
    • Keep the GCS role on the expansion server, but deactivate the role until both the main and expansion servers are running the same version of Security Center.
Supported integrated software
Plugin users might need to upgrade their integrated software to a version supported by Security Center 5.8 GA. For more information, refer to Supported plugins in Security Center.
For instructions about how to upgrade Security Center, see Installing Security Center.