Software requirements for Security Center 5.9 Web Client - Security Center 5.9

Security Center System Requirements Guide 5.9

Applies to
Security Center 5.9
Last updated
2020-11-05
Content type
System requirements
Language
English (United States)
Product line
Security Center unified platform > Security Center
Version
5.9

Before using Web Client, familiarize yourself with the operating systems and browsers that are supported with Web Client.

The software requirements for Security Center 5.9 Web Client are the following:
Operating system Supported Browsers

Microsoft® Windows 10 Professional and Enterprise (32-bit or 64-bit)

Microsoft® Windows 8.1 Professional and Enterprise (32-bit or 64-bit)

  • Microsoft Internet Explorer 11 or higher
  • Microsoft Edge for Windows 10
  • Google Chrome 68 or later
  • Mozilla Firefox 61 or later

Microsoft® Windows Server® 2012 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2016 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2017 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2019 Standard Edition and R2 (32-bit or 64-bit)

  • Microsoft Internet Explorer 11 or higher
  • Google Chrome 68 or later
  • Mozilla Firefox 61 or later
Mac OS X 10.9.1 Apple Safari (desktop version)
NOTE: If you are not seeing high-quality (H.264) video in your Firefox browser, make sure that H.264/avc3 on the media source extension is enabled.
NOTE: Apple Safari for iOS and Google Chrome for Android devices are not supported by Security Center 5.9 Web Client. To access Security Center videos and data from your smartphone, you should use Genetec™ Mobile.