Upgrading to deister proxSafe plugin 3.1 - deister proxSafe 3.1

deister proxSafe Plugin Guide 3.1

Applies to
deister proxSafe 3.1
Last updated
2022-07-14
Content type
Guides > Plugin and extension guides
Language
English (United States)
Product
deister proxSafe
Version
3.1

There is no direct upgrade path from deister proxSafe 3.0 to 3.1. To move to version 3.1 of the plugin, you must uninstall the earlier plugin version, install the latest version, and recreate your configurations.

Before you begin

  • Read the release notes to learn about important information for this release.
  • Confirm that your versions of Security Center, the deister proxSafe key management system, and the plugin are compatible.
  • Back up your deister proxSafe Commander database. For more information, see your deister documentation.

What you should know

  • The latest version of the plugin must be installed on all Security Center client and server computers.
  • During the upgrade process, all existing data will be deleted.

Procedure

  1. (Optional) Back up your databases:
    1. Open Server Admin, and back up the Directory database.
    2. Back up the plugin role database.
    NOTE: It is a best practice to back up your databases if you need to revert to the previous plugin version for any reason.
  2. Take screenshots of your plugin configuration settings.
  3. Delete the deister proxSafe plugin role.
  4. In Windows, open Control Panel > Programs > Programs and Features and uninstall the plugin.
  5. Install the latest version of the plugin.
    IMPORTANT: Do not reuse your deister proxSafe plugin 3.0 database when installing version 3.1.

Results

deister proxSafe plugin 3.1 is ready for use.