[KBA-79083] PTZ not working on Axis Q1793-LE cameras - Axis Q1798-LE cameras do not have optical zoom PTZ capabilities in Security Center. - Security Center 5.8.1.2 - 5.8.1.10, 5.9.0.0 - 5.9.4.3, and 5.10.0.0

Product
Security Center
Internal reference number
2835296
Content type
KB articles
Version
5.10
5.9
5.8
Language
English
Last updated
2023-03-08

[KBA-79083] PTZ not working on Axis Q1793-LE cameras

Axis Q1798-LE cameras do not have optical zoom PTZ capabilities in Security Center.

Applies to

Security Center 5.8.1.2 - 5.8.1.10, 5.9.0.0 - 5.9.4.3, and 5.10.0.0

Symptoms

When you add an Axis Q1798-LE camera to Security Center, it cannot use optical zoom. If you try to enable PTZ capability from the camera's Hardware tab, you are asked for the serial port, and the PTZ capability option does not stay on.

Cause

PTZ capability is missing on the Axis driver for this model.

Workaround

If you are running Security Center 5.8.1.2 - 5.8.1.10, 5.9.0.0 - 5.9.4.3, or 5.10.0.0, add the PTZ Support tag to the camera's configuration file:
  1. On the Archiver server, open the C:\Program Files (x86)\Genetec Security Center 5.x\Extensions\AxisExtension.xml file in Notepad.
  2. Click Edit > Find and search for: AXIS Q1798-LE.
  3. At the end of the DeviceSpecs section, enter the following:
    <Specification Name="PTZ_Is_Supported" Value="true" />
    For example:
    <DeviceSpecs Product="AXIS Q1798-LE" EntityType="Unit" Extends="default" >
        <Specification Name="Audio_Decoder_Supported" Value="false"/>
        <Specification Name="PTZ_Is_Supported" Value="true" />
    </DeviceSpecs>
  4. Save the file, and restart the Archiver role associated to the camera by deactivating and activating the role.

Status

This issue is resolved in Security Center 5.8.1.11, 5.9.4.4, and 5.10.1.0. For Security Center 5.10.0.0, you can also contact Technical Support and install Driver Package 10.1.