El sistema tarda demasiado en activar incidentes - Genetec Mission Control™ 2.12.1.0

Guía del Usuario de Genetec Mission Control™ 2.12.1.0

Applies to
Genetec Mission Control™ 2.12.1.0
Last updated
2019-11-12
Language
Español
Product
Genetec Mission Control™
Version
2.12

Cuando el sistema tarda demasiado en activar incidentes, puede resolver el problema al filtrar eventos innecesarios de la cola de eventos de RabbitMQ.

Síntomas

Los incidentes no se activan de manera oportuna en Genetec Mission Control™.

Motivo

Dependiendo de la configuración del sistema y sus entidades conectadas, la función del Directory podría estar enviando demasiados eventos al servidor de RabbitMQ de Genetec Mission Control™. Esto hace que la cola de eventos sea demasiado grande para procesar eventos nuevos y, de este modo, crea una demora en activar incidentes. Puede encontrar detalles sobre el número de eventos en cola y la tasa de respuesta del servidor de RabbitMQ en https://localhost:15671.

Solución

  1. Detenga la función del Incident Manager en la Config Tool:
    • Vaya a Sistema > Funciones > Incident Manager.
    • Haga clic con el botón derecho en Incident Manager.
    • Seleccione Mantenimiento > Desactivar función.
  2. Inicie sesión en el servicio de RabbitMQ desde https://localhost:15671.
  3. Haga clic en la pestaña de Colas y luego en ExternalEventsQueue.
  4. Haga clic en Purgar y, luego, en Purgar mensajes para borrar la cola.
  5. Vuelva a activar la función del Incident Manager:
    • Vaya a Sistema > Funciones > Incident Manager.
    • Haga clic con el botón derecho en Incident Manager.
    • Seleccione Mantenimiento > Activar función.
  6. Filtre los eventos que no necesita en la configuración de su Genetec Mission Control™:
    1. En la Config Tool, vaya a Sistema > Funciones > Incident Manager.
    2. Haga clic en la pestaña de Eventos.
    3. Deseleccione los eventos que no necesita.

    Para obtener más información sobre la filtración de eventos, consulte Especificar eventos permitidos para Genetec Mission Control™.