Si la función del Incident Manager en la Config Tool se desconecta porque no puede conectarse al servicio de RabbitMQ, puede resolver el problema de conexión al verificar algunos ajustes pertinentes, como puertos de firewall, credenciales de usuario y demás.
Síntomas
La función del Incident Manager en la Config Tool está en rojo y, cuando hace clic en , recibe el siguiente mensaje de error: La conexión RabbitMQ falló - <dirección IP del servidor> intentará de nuevo en x segundos
Motivo
El servidor que ejecuta la función del Incident Manager no se puede conectar al servicio de RabbitMQ que se ejecuta en el puerto 5671 (puerto predeterminado) con una conexión de Capa de Puertos Seguros (SSL, por sus siglas en inglés).
Solución
Pruebe con una o una combinación de las siguientes soluciones:
- En Windows, vaya a y asegúrese de que el servicio de RabbitMQ se haya iniciado de manera correcta en el servidor en el que está instalado.
- Desde las pestañas de configuración de la función del Incident Manager en la Config Tool, asegúrese de estar usando el Nombre de usuario y la Contraseña correctos para la conexión con RabbitMQ. ElNombre de usuario y la Contraseña se crearon durante la instalación de Genetec Mission Control™.
- Reemplace el nombre del servidor de RabbitMQ con la dirección IP del servidor o asegúrese de que el nombre del servidor esté vacío. La siguiente imagen muestra un ejemplo de la pantalla de inicio de sesión de RabbitMQ:
- Asegúrese de que el servidor que ejecute la función del Incident Manager pueda tener acceso al servidor que ejecuta RabbitMQ en el puerto 5671.CONSEJO: Abra el símbolo del sistema e introduzca lo siguiente:
telnet <server IP address> 5671
Si los servidores se están comunicando de forma apropiada, recibirá una respuesta. - Asegúrese de que todos los puertos de firewall permitan conexiones TCP en ambos sentidos entre el servidor de Genetec Mission Control™ y el servidor de RabbitMQ, en el puerto 5671.