Restablecer contraseñas para cuentas de usuario de RabbitMQ - Genetec Mission Control™ 2.12.1.0

Guía del Usuario de Genetec Mission Control™ 2.12.1.0

Applies to
Genetec Mission Control™ 2.12.1.0
Last updated
2019-11-12
Language
Español
Product
Genetec Mission Control™
Version
2.12

Si pierde la contraseña de la cuenta de RabbitMQ que se creó durante la instalación de Genetec Mission Control™, puede cambiar la contraseña desde el símbolo del sistema de RabbitMQ.

Síntomas

La función del Incident Manager en la Config Tool está en rojo.

Motivo

Sin credenciales de inicio de sesión de RabbitMQ válidas, no puede conectarse al servicio de RabbitMQ desde la Config Tool. Sin establecer una conexión, la función del Incident Manager se desconecta y se torna roja.

Solución

Para restablecer la contraseña de su cuenta de RabbitMQ:
  1. Abra un símbolo del sistema elevado en Windows:
    1. En el cuadro de búsqueda de Windows, escriba cmd.
    2. Presione Ctrl+Shift+Enter.

      La ventana de Control de Cuentas de Usuario se abre y le indica que ejecute como administrador.

    3. Haga clic en .
  2. Navegue hasta la carpeta sbin de RabbitMQ.
    NOTA: En general, se encuentra en C:\Program Files\RabbitMQ Server\rabbitmq_server-x.y.z\sbin.
  3. Para ver la lista actual de usuarios en RabbitMQ, ejecute el siguiente comando:

    rabbitmqctl list_users

  4. Restablezca la contraseña de su cuenta específica de RabbitMQ al ejecutar el siguiente comando:

    rabbitmqctl change_password <usuario><nueva contraseña>

    NOTA: Si un error de autenticación de cookies de Erlang impide que se ejecuten los comandos rabbitmqctl, debe sincronizar los archivos .erlang.cookie en su máquina. Para obtener más información, consulte las instrucciones de instalación de RabbitMQ.
  5. Actualice las credenciales de inicio de sesión de RabbitMQ en Config Tool debajo de Incident Manager > Propiedades.