[KBA-79091] Problèmes avec le Répertoire et les clients en raison de la taille importante de la table Application - Cet article décrit les symptômes dans Security Center entraînés par une taille importante de la table Application dans la base de données du Répertoire. - Security Center 5.8.1.2 - 5.8.1.7, 5.9.1.0 - 5.9.4.2, 5.10.0.0

Product
Security Center
Content type
Articles de la BC
Version
5.10
5.9
Language
Français
Last updated
2021-10-15

[KBA-79091] Problèmes de Répertoire et avec les clients en raison de la taille importante de la table Application

Cet article décrit les symptômes dans Security Center entraînés par une taille importante de la table Application dans la base de données du Répertoire.

Concerne

Security Center 5.8.1.2 - 5.8.1.7, 5.9.1.0 - 5.9.4.2, 5.10.0.0

Symptômes

Symptômes courants :
  • Le Répertoire ne démarre pas ou met longtemps à démarrer.
  • Deux heures après le démarrage normal du Répertoire, Config Tool ou Security Desk se bloque à la connexion ou lors de de l’exécution de certaines actions.
  • Le Répertoire commence à utiliser une quantité excessive de mémoire, ou de ressources processeur ou réseau.
  • Les rôles basculent hors ligne après une erreur de dépassement de délai. Le dépassement de délai est consigné dans les journaux de l’observateur d’événements Windows.

Cause

En raison d'un problème de code, le mécanisme de nettoyage de la table Application ne fonctionne pas comme prévu.

Pour savoir si votre système est affecté, exécutez le script SQL en lecture seule sur votre base de données de Répertoire pour voir la taille de la table Application :
Code
SELECT 
COUNT(1) [Count]
FROM [Application]
WHERE [Type] in (2,22,8,1,11,9,10,5,6,28,7,17,23,24,13,29,25,31)

Si le résultat du script affiche plus de 1 000 applications, votre système est peut-être affecté par ce problème. Pour en savoir plus, veuillez contacter l’assistance technique de Genetec™.

Contournement

Un script de nettoyage manuel est disponible pour traiter le problème. Pour obtenir le script, contactez l'assistance technique de Genetec.

État

Ce problème est résolu dans les versions Security Center suivantes :
  • 5.8.1.8 et les versions ultérieures de la 5.8
  • 5.9.4.3 et les versions ultérieures de la 5.9
  • 5.10.1.0 ou ultérieur
Nous vous recommandons d’exécuter le script de nettoyage manuel après la mise à niveau de votre système.