[KBA-01378] Issues with controlling doors and video streaming using GSC Mobile app 3.x - Security Center Mobile 3.0 - 3.2

series
Security Center Mobile 3.0 - 3.2
revised_modified
2015-03-13

[KBA-01378] Issues with controlling doors and video streaming using GSC Mobile app 3.x

This article explains why you might be unable to control doors in the GSC Mobile app 3.x, and why video streaming might cause the Mobile app to close unexpectedly.

Symptoms

  • When you try to monitor a door in the GSC Mobile app on an Apple device, you receive the following error message:
    Connection lost. The event stream has been closed.

    The door controls are also greyed out.

  • When you try to stream video to the mobile device, the app sometimes closes unexpectedly.

Cause

SSLv2 and SSLv3 are disabled on the server, and one or both of the following conditions are true:

  • Mobile Server is using a self-signed certificate
  • Mobile Server is running Windows Server 2012.

Workaround

If you are using a valid SSL certificate, update GSC Mobile to version 4.0.53 or later to fix the problem.

If Mobile Server is running Windows Server 2012 and you are using a self-signed certificate, the only way to resolve this problem is to generate another self-signed certificate with IIS, and select it in Mobile Admin.

NOTE: Using a self-signed certificate is not recommended in production environments.

Contact your network administrator for help with server certificates, and consult Encrypting communication between Security Center Mobile components for instructions on applying a certificate.

To confirm that the SSL certificate is causing this problem, you can try disabling HTTPS in the Mobile Admin Mobile Connectivity webpage and recheck for symptoms.

NOTE: Disabling HTTPS is not recommended in production environments.

Status

This issue is resolved in GSC Mobile 4.0.53 or later.

For servers running on Windows Server 2012 with self-signed certificates, this issue is resolved in GSC Mobile 3.3.