[KBA-77061] LPR Manager Database does not connect after upgrading to Security Center 5.6 SR2 - Security Center 5.6 SR2

series
Security Center 5.6 SR2
revised_modified
2017-07-11

[KBA-77061] LPR Manager Database does not connect after upgrading to Security Center 5.6 SR2

This article explains why the LPR Manager Database might not upgrade after upgrading to Security Center to 5.6 SR2.

Summary

If your database version is SQL Server 2008 R2, the LPR Manager might not upgrade following an upgrade to Security Center 5.6 SR2. Also, you might not be able to create an LPR Manager Database correctly and you might also see errors in the console log and event log.
CAUTION:
If you are running SQL Server 2008 R2, it is strongly recommended to back up the database on the setup before upgrading to SQL Server Database 2012 (or higher) and before upgrading to Security Center 5.6 SR2.

Symptoms

You might see one or more of the following error messages:

  • Failure to connect to the LPR Manager database

  • Failure to create an LPR Manager database

  • Failure to connect to the Archiver role by the LPR Manager

You also see the following error message in the Windows event logs:
Database Manager - Unexpected logging error. Details: Genetec.Data.SqlCommandException: Exception occurred while executing a sql command
(Retry count = 0) ---> System.Data.SqlClient.SqlException: Incorrect syntax near 'THROW'. 
At System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action'1 wrapCloseInAction)

Cause

There is a query command that is not supported in SQL version 2008 R2, however, it is supported in SQL version 2012 and later.

Workaround

If you encounter this issue, do one of the following:
  • Upgrade the SQL Server 2008 R2 to 2012 or higher
  • Install the hotfix
To install the hotfix, do the following:
  1. Open the Security Center installation directory (default is C:\Program Files (x86) \Genetec Security Center 5.6).
  2. Rename Genetec.LicensePlateManagement.Data.dll to Genetec.LicensePlateManagement.Data_BACKUP.dll.
  3. Install this hotfix. Because the hotfix is a self-install .exe file, it installs automatically.
    NOTE: Make sure that the hotfix is not blocked before extracting the executable file.
  4. Open Config Tool.
The LPR Manager role is now running. If you have questions or encounter issues, contact Genetecâ„¢ Technical Assistance Center.