[KBA-01015] “No Valid Language Resource.dll” error when launching Server Admin in Omnicast™ - Omnicast™ 4.6 - 4.8

series
Omnicast™ 4.6 - 4.8
revised_modified
2012-07-31

[KBA-01015] “No Valid Language Resource.dll” error when launching Server Admin in Omnicast™

This article explains why you might get a No Valid Language Resource.dll error when launching the Server Admin in Omnicast™ after restoring another server’s registry keys.

Symptoms

When launching the Server Admin in Omnicast™ after restoring registry keys, you receive an error that states there is no valid language library available:
No Valid Language Resource.dll

This error does not affect the functionality of the server.

Cause

The resource library was not installed properly or the registry keys were not restored properly.

Workaround

  1. Close the Server Admin and client applications (Live Viewer, Config Tool, and Archive Player)
  2. Stop all the Omnicast™ services from the Genetec™ Watchdog or from Windows services.
  3. Open the Windows Registry Editor.
  4. Browse to either:
    • HKLM\Software\Genetec\Genetec Omnicast 4.x
    • HKLM\Software\Wow6432Node\Genetec\Genetec Omnicast 4.x
  5. On the right side, verify the Data column of the Resourcesfolder key. Ensure the path that is listed matches the actual path where Omnicast™ is installed on the server.

  6. If the path does not match, double-click the ResourcesFolder key and add the correct path in the Value Data field.
  7. Restart the Omnicast™ services.