[KBA-75526] Software stops working properly after the Sipelia™ 2.3 GA installer updates RabbitMQ - Sipelia™ 2.3 GA

series
Sipelia™ 2.3 GA
revised_modified
2016-12-21

[KBA-75526] Software stops working properly after the Sipelia™ 2.3 GA installer updates RabbitMQ

This article describes the impact of upgrading your version of RabbitMQ, using the Sipelia™ 2.3 GA installer.

Summary

When installing the Sipelia™ 2.3 GA module (server only, not client), the installer upgrades the existing installations of RabbitMQ and its prerequisite, Erlang, to the following versions:
  • RabbitMQ 3.6.4
  • Erlang OTP 19 (8.0)

Because the RabbitMQ software is not backward compatible, upgrading it might break other installed software that also use RabbitMQ.

An example of a software that also uses RabbitMQ is Genetec Mission Control™, versions 2.2 and earlier. Genetec Mission Control™ stops working properly when deploying Sipelia™ 2.3 GA server on a machine that has an earlier version of the RabbitMQ server installed, and in which Genetec Mission Control™ is configured to use that particular RabbitMQ server.

Symptoms

Genetec Mission Control™ (versions 2.2 or earlier) or other installed software that uses RabbitMQ, stops working properly.

Cause

Installing Sipelia™ 2.3 GA server upgrades the existing versions of RabbitMQ and Erlang.

Workaround

You can deploy Sipelia™ 2.3 GA server on a separate machine, that is, a machine in which the RabbitMQ server is not being used by other software. As a result, you will have two instances of RabbitMQ: an earlier version that is required by Genetec Mission Control™ (or other software) and a new version that only Sipelia™ needs.

More Information

RabbitMQ is a prerequisite for Security Center 5.3 - 5.5 only.