[KBA-00989] Error when restoring backup sets using the Omnicast™ SDK - Omnicast™ 4.6 - 4.8

series
Omnicast™ 4.6 - 4.8
revised_modified
2012-06-22

[KBA-00989] Error when restoring backup sets using the Omnicast™ SDK

This article explains why an exception might be generated when restoring backup sets on the Restore Archiver using the Omnicast™ SDK.

Symptoms

When restoring backup sets on a Restore Archiver using the Omnicast™ SDK, an exception is generated when a sequence overlaps a sequence from previously restored backup sets.

Cause

When restoring backup sets through the Server Admin, you receive the following message when an overlap occurs:

Users can force the restore by clicking Yes in the dialog box. However, when using the Omnicast™ SDK, there is no way to force the restore. This results in an exception being generated.

Workaround

Restore backup sets using the Server Admin.

Status

Hotfixes are available for Omnicast™ 4.6 SR1 (HF1190) and Omnicast™ 4.8 SR1 HIP1 (HF75561 or later). Contact the Genetec™ Technical Assistance Center to obtain them.

This issue is fixed in Omnicast™ 4.8 SR2.