[KBA-79020] Cannot add some Zenitel TCIV intercoms as cameras in Security Center 5.8 GA or later - Security Center 5.8 GA and later

series
Security Center 5.8 GA and later
revised_modified
2020-01-08

[KBA-79020] Cannot add some Zenitel TCIV intercoms as cameras in Security Center 5.8 GA or later

This article explains why you are unable to add a Zenitel TCIV2, TCIV3, or TCIV6 intercom as a camera in Security Center and use it as intercom at the same time.

Symptoms

If you add a Zenitel TCIV2, TCIV3, or TCIV6 intercom in Security Center using Vingtor-Stentofon as the Manufacturer, you can only use the intercom as camera and not as an intercom.

Cause

SIP calls use H.264. However, adding a Zenitel intercom using Vingtor-Stentofon as the Manufacturer forces you to use MJPG HTTP, which means that you can only use the intercom as camera. This is an external issue.

Workaround

To add the intercom in Security Center as a camera and still use it as an intercom:
  1. Upgrade the firmware on the intercom to version 4.11.3 or later.
  2. In the SIP Configuration section on the intercom webpage, set the Video mode option to ONVIF for the primary stream, and the Video mode option to SIP Call H.264 for the secondary streams.
  3. Add the video unit in Security Center using the following settings:
    Manufacturer
    ONVIF
    HTTP Port
    8095
  4. After adding the video unit, try viewing live video. If you receive a Transmission lost error, do the following:
    1. On the server that is hosting the Archiver role which manages the intercom, navigate to C:\Program Files (x86)\Genetec Security Center 5.x\Extensions\Drivers.
    2. Modify the OnvifUnitConfiguration.xml file by adding the following code after the default H264 video stream:
      <Capabilities Param="VideoInput_Stream_Rtcp_KeepAlive" Value="10" />
    3. Save the file and restart Genetec Server services.

You should now be able to stream live video.

Status

This issue is fixed with firmware 4.11.3 for Zenitel TCIV intercoms.