Supported HID controller firmware in Security Center 5.6 SR2 - Security Center 5.6 SR2

Security Center Release Notes 5.6 SR2

series
Security Center 5.6 SR2
revised_modified
2017-06-27

Genetec Inc. recommends a specific firmware version for each generation of HID controllers, old (Legacy) and new (EVO). Using earlier firmware versions might cause issues with your system.

Security Center works best when the HID controllers are running the recommended certified firmware versions.
Supported firmware Legacy controllers EVO controllers
Recommended certified firmware 2.2.7.568 3.6.2.101
Minimum supported firmware 2.2.7.568 3.5.x

Previously supported firmware versions

To learn about the issues with the previously supported firmware versions, see Limitations in Security Center 5.6 SR2.

HID EVO firmware upgrade procedure

To upgrade your HID EVO units from an earlier firmware version (2.3.1.603 or 2.3.1.605 for Edge EVO, and 2.3.1.542 or 2.3.1.673 for VertX EVO) to the recommended firmware version, specific upgrade paths must be followed.
  • HID Edge EVO: (EH400, EH400-K)

    Supported upgrade path: 2.3.1.603 or 2.3.1.605 → 2.3.1.841 → any later version

  • HID Vertx EVO: (V1000, V2000)

    Supported upgrade path: 2.3.1.542 or 2.3.1.673 → 2.3.1.791 → any later version

CAUTION:
Upgrading directly from the earlier firmware to the recommended firmware will cause irreparable damage to your unit. Moreover, you cannot downgrade the firmware after it has been upgraded to 2.3.1.841 on Edge EVO or to 2.3.1.791 on VertX EVO.

For the upgrade procedure, see Upgrading access control unit firmware.