Upgrading Security Center from 5.4, 5.5, or 5.6 to 5.7 - Security Center 5.7 GA

Security Center Installation and Upgrade Guide 5.7 GA

series
Security Center 5.7 GA
revised_modified
2017-10-25

To have the latest version of Security Center, you can upgrade from an earlier version (5.4 through 5.6) to 5.7 in a single step.

What you should know

This process also applies to upgrades from Security Center 5.3 and earlier if you plan to upgrade all your servers and workstations at the same time.

Not all tasks and roles work in backward compatibility mode. If you plan to upgrade your system in stages, make sure that the features that are essential to your operation are supported. See Backward compatibility requirements for Security Center.

NOTE: A role is upgraded only if you upgrade the server hosting the role. If you only upgrade the main server, the roles hosted on the expansion servers that are not yet upgraded work in backward compatibility mode.
IMPORTANT: If you upgrade the LPR Manager, the Archiver it is linked to must also be upgraded. The upgraded LPR Manager would not work if the Archiver is working in backward compatibility mode.

Procedure

  1. If Omnicast™ systems were federated to your previous Security Center system, uninstall the previously installed compatibility packs.
  2. Do one of the following:
  3. Upgrade the rest of your system according to your priorities and schedule.
    If both Security Center Client and Server are installed on the same machine, upgrade them together.
    IMPORTANT: Make sure to note and apply the same settings as used for your previous installation: passwords, databases, ports, general properties, and so on.

After you finish

  • Starting from 5.7 GA, many privileges that used to be exclusive to administrators can now be granted individually. Although your previous settings will continue to work, you might want to use this opportunity to revise the privileges of your user groups, granting to each group only the privileges they need.
    CAUTION:
    Users who were system administrators or partition administrators before the upgrade to 5.7 will keep their privileges. Users who were not adminsitrators who had either the privilege to change logical IDs or to create event-to-actions will loose these privileges after the upgrade. If you want them to keep these privileges, you must grant them explicitly the Modify logical IDs privilege or the Modify event-to-actions privilege.
  • If the file AllowedSynchronizationConfiguration.xml was used to set the synchronization times of your HID VertX units, the settings must be re-applied manually from Config Tool after the upgrade.
    Tip: Configure one unit with the required synchronization settings, then use the Copy configuration tool to set the same settings on multiple units.
  • If AutoVu™ is enabled, migrate the LPR databases to the Security Center 5.7 GA structure.