Disabling backward compatibility - Security Center 5.7 GA

Security Center Installation and Upgrade Guide 5.7 GA

series
Security Center 5.7 GA
revised_modified
2017-10-25

Older versions of Security Center (prior to 5.4) do not support the Transport Layer Security protocol. Therefore, supporting them makes your system more vulnerable to network attacks. To increase the security of your system, you can disable backward compatibility.

What you should know

Backward compatibility is enabled by default at system installation. This option applies to the entire system.
CAUTION:
Mobile Server 4.0 does not support TLS. Disabling backward compatibility means that the Mobile apps and the Web Clients 4.0 will no longer be able to connect to Security Center. All expansion servers that have not yet been upgraded to version 5.4 or later will also stop to work. Both Web Client 4.1 and the role-based Web Client 5.6 and later support TLS.

Procedure

  1. Connect to Server Admin of your main server with a web browser.
  2. Click the main server () in the server list.
  3. Under Secure communication, clear the Allow unauthenticated connections (5.3 and earlier) option.
  4. Click Save.

Results

Backward compatibility is disabled. The next time someone tries to connect to your system with an older Security Center application, they will get the Client-server versions are incompatible error.