[KBA-78977] Video units offline and Archiver role displays “Unit control failed to start on server” warning - Security Center 5.2 - 5.7

series
Security Center 5.2 - 5.7
revised_modified
2019-05-15

[KBA-78977] Video units offline and Archiver role displays “Unit control failed to start on server” warning

This article explains why video units remain offline in Security Center and the Archiver role displays a Unit control failed to start on server warning after the Archiver server or the Genetec™ Server service restarts.

Symptoms

After an Archiver server restarts or the Genetec™ Server service restarts, video units that are managed by the Archiver role remain offline. The Archiver role is online, but displays the following warning message:
  • Security Center 5.6 – 5.7: Unit control failed to start on server

  • Security Center 5.5 or earlier: Agent failed to start on server

Cause

There is an invalid vertical bar symbol ("|") in the Archiver role name.

Workaround

To get the video units online, do the following:
  1. Remove the invalid symbols by renaming the Archiver role.
  2. Deactivate the Archiver role.
  3. (Only for Security Center 5.6 - 5.7) If you have multiple roles hosted on the same server, do the following:
    1. Navigate to C:\Program Files (x86)\Genetec Security Center 5.x\ConfigurationFiles.
    2. Open the GenetecServer.PersistentServices.gconfig file.
    3. Search for the following section:
      <add key="UnitControlConfig"
    4. Add the value 1 to the UnitControlConfig key:
      <add key="UnitControlConfig1"
    5. Save the GenetecServer.PersistentServices.gconfig file.
  4. Restart the Genetec™ Server service.
  5. Activate the Archiver role.

Status

This issue is resolved in Security Center 5.8 GA and later.