Supported HID firmware versions - Security Center 5.8

Security Center Administrator Guide 5.8

series
Security Center 5.8
revised_modified
2020-08-17

We recommend a specific firmware version for each generation of HID controllers, old (Legacy) and new (EVO). Using earlier firmware versions might cause issues with your system.

Security Center works best when the HID controllers are running the recommended certified firmware versions.
Supported firmware Legacy controllers EVO controllers
Recommended certified firmware 2.2.7.568 3.8.01
Minimum supported firmware 2.2.7.568 3.5.x

1As of Security Center 5.8, HID units running firmware version 3.7.0.108 or later in secure mode communicate with the Access Manager using TLS 1.2 encryption over TCP port 4433. HID units running an earlier firmware version or in regular mode communicate with the Access Manager using HID encryption.

For more information about port changes, see Firewall ports used by Synergis™ applications in Security Center.

Previously supported firmware versions

To learn about issues with the previously supported firmware versions, see Limitations in Security Center.

Upgrading HID EVO firmware

Specific upgrade paths must be followed to upgrade the following HID EVO units from the firmware versions indicated to the recommended firmware version:

  • Edge EVO: 2.3.1.603 or 2.3.1.605
  • VertXEVO: 2.3.1.542 or 2.3.1.673