[KBA-79012] Pelco PTZ cameras go offline when using PTZ controls in Security Center and non-PTZ cameras display Transmission lost warnings - Security Center 5.8 GA

series
Security Center 5.8 GA
revised_modified
2019-11-12

[KBA-79012] Pelco PTZ cameras go offline when using PTZ controls in Security Center and non-PTZ cameras display Transmission lost warnings

This article explains why after upgrading from Omnicastâ„¢ 4.8 to Security Center 5.8 GA, PTZ controls on Pelco TXB-N, IES0DN, and D5230 units stop working and the units go offline, and regular Pelco units display Transmission lost warnings.

Applies to: Security Center 5.8 GA

Symptoms

After upgrading from Omnicastâ„¢ 4.8 to Security Center 5.8 GA, the following occurs:
  • When you try to use PTZ controls on Pelco PTZ units the units go offline.
  • Regular Pelco units randomly display a Transmission Lost warning.
  • The PTZ protocol in the Hardware tab of Pelco units is Generic Plus instead of Pelco IP.

Cause

  • After upgrading from Omnicastâ„¢ 4.8 to Security Center 5.8 GA, Pelco units are moved to the wrong Archiver extension.
  • The Pelco unit was added in Security Center using the incorrect Product type option. The Pelco and Generic Plus Archiver role extensions are both based on the ONVIF protocol. If the incorrect Product type is selected, the unit is added under the Generic Plus extension instead of the Pelco extension.

Workaround

  1. Delete the Pelco unit from Config Tool.
    NOTE: You do not have to delete the video recordings for the unit.
  2. Add Pelco unit again with the following settings:
    Manufacturer
    Pelco
    Product type
    All

    The unit should be added under the Pelco extension, and the PTZ protocol in the Hardware tab of the unit should be Pelco IP.