[KBA-00981] Omnicast™ Gateway service keeps restarting on Windows 2008 Servers - Omnicast™ 4.6 - 4.8

series
Omnicast™ 4.6 - 4.8
revised_modified
2012-06-19

[KBA-00981] Omnicast™ Gateway service keeps restarting on Windows 2008 Servers

This article explains why the Omnicast™ Gateway service might unexpectedly restart on a Windows 2008 server.

Symptoms

The Omnicast™ Gateway service restarts frequently. The following error message is displayed inside the Gateway service console: Ping failed on thread: Connection Manager Thread

Cause

The ntdll.dll file freezes during a Winsock close function. This causes some processes to time out during the attempt to close network communication channels.

Workaround

Recommendations we received from Microsoft suggest to do the following:
  1. Update the NIC drivers.
  2. If it is a Broadcom NIC, try replacing with an Intel card.
  3. As a last resort, re-install Windows, which in most cases has resolved the problem.

If after re-installing Windows the problem is not resolved, contact the Genetec™ Technical Assistance Center for further assistance.