[KBA-76407] Upgrade to Security Center 5.6 GA is blocked even when there is no AutoVu™ feature enabled in the Security Center license - Security Center 5.6 GA

series
Security Center 5.6 GA
revised_modified
2017-04-11

[KBA-76407] Upgrade to Security Center 5.6 GA is blocked even when there is no AutoVu™ feature enabled in the Security Center license

This article explains why your upgrade from Security Center 5.5 or earlier to 5.6 GA might fail, even after you have removed all AutoVu™ features from your license and reapplied the license to your system before the upgrade. It also provides a workaround solution.

Summary

AutoVu™ features are not supported in Security Center 5.6 GA. As a result, you cannot upgrade your Security Center system from 5.5 or earlier to 5.6 GA if AutoVu™ features are enabled in your Security Center license.

Symptoms

If you run the Security Center 5.6 GA Installer on a system that has AutoVu™ features enabled, you get the following message:

If you remove the AutoVu™ features from your license and reapply the license to your system before the upgrade, the upgrade is successful. However, when you start Server Admin, you need to update the Directory database. If you try to update the Directory database, you get an error message stating that the database update failed because at least one LPR Manager role is detected in your system.

Cause

AutoVu™ features are not supported in Security Center 5.6 GA, and Security Center 5.6 GA does not run if it detects the LPR Manager in your system.

Workaround

To upgrade your Security Center system from version 5.5 or earlier to 5.6 GA, you must first remove all AutoVu™ features from your Security Center license. You must also delete all LPR Manager roles from your system to remain compatible with your license.

If you tried to upgrade and were blocked by Server Admin, do the following:
  1. Restore the Security Center 5.5 Directory database from the backup you created before your upgrade to 5.6 GA.
  2. If necessary, re-install Security Center 5.5 Config Tool on a client workstation.
  3. Using the 5.5 Config Tool, connect to your Security Center 5.5 Directory.
  4. Open the System task and click Roles.
  5. Delete all LPR Manager roles that exist in your system.
  6. Run the Security Center 5.6 GA Installer again.
If you did not back up your Security Center 5.5 Directory database before the upgrade, do the following:
  1. On the main server, go to the Configuration Files subfolder under the Security Center 5.6 installation folder, and open the file GeneralSettings.gconfig with a text editor.
  2. Add the following entry in the <configuration> section: <special56Ga allowDbUpgradeWithLpr="true" />
  3. Save your changes and restart the Genetec™ Server service.
  4. Using the 5.6 Config Tool, connect to your Security Center 5.6 Directory.
  5. Open the System task and click Roles.
  6. Delete all LPR Manager roles that exist in your system.

All AutoVu™ entities are permanently deleted.