[KBA-79028] Decoders stop displaying video after Archiver failover in Security Center - Security Center

series
Security Center
revised_modified
2020-02-07
TFSnum
2320200

[KBA-79028] Decoders stop displaying video after Archiver failover in Security Center

This article explains why decoders no longer display video after an Archiver failover event in Security Center, and what you can do to fix it.

Symptoms

When an Archiver role fails over and comes back online, monitors connected to decoders turn black and no longer display video.

Cause

This behavior is as designed.

Workaround

To fix this issue, do one of the following:
  • Disconnect the camera from the decoder tile in Security Desk, and then drag the camera back into the tile.
  • Reconnect the decoder from Config Tool.
Video is now displayed on the camera connected to the decoder.
To prevent this behavior in the future:
  1. On the primary Archiver server, open the Server Admin.
  2. Select the primary Archiver server and click Actions > Console > Commands.
  3. Expand Archiver Role commands and click ForceExecutionOnPrimary.
  4. To enable the ForceExecutionOnPrimary option, type true and click OK.

    If the operation is successful, you receive a Succeeded message.

  5. Repeat the steps for each server that hosts an Archiver role which manages a decoder.

If you change the primary Archiver server for an Archiver role, you must perform this workaround again.