[KBA-00764] Security Desk and Config Tool freeze or disconnect when another client connects - Security Center 5.2 - 5.7

series
Security Center 5.2 - 5.7
revised_modified
2019-01-25

[KBA-00764] Security Desk and Config Tool freeze or disconnect when another client connects

This article explains how to resolve Security Desk or Config Tool connection issues when using cloned (or ghosted) workstations.

Applies to: Security Center 5.2 - 5.7

Symptoms

A Security Desk workstation loses its connection when another Security Desk workstation connects to the Directory, if one of the workstations is cloned (or ghosted). This issue also occurs with Config Tool workstations.

Cause

Each Security Desk application is identified by a unique GUID. If you clone or ghost a workstation using a pre-installed Security Desk application, the GUID is duplicated. The same process applies to Config Tool applications.

If two workstations with the same GUID connect to the server, the Directory assumes it is the same workstation connecting twice and will disconnect the first one.

Workaround

To resolve this issue, perform the following actions on the affected computers:
  1. Stop Security Desk and Config Tool.
  2. Navigate to the following folder:
    Security Center 5.2
    C:\ProgramData\Genetec Security Center 5.x
    Security Center 5.3 and later
    C:\Users\<username>\AppData\Local\Genetec Security Center 5.x
  3. Add a .bak extension to the following files:
    • SecurityDesk.Workspace.Settings
    • ConfigTool.Workspace.Settings
  4. Restart Security Desk and Config Tool.