Troubleshooting body-worn cameras in Security Center
If you are experiencing problems with body-worn camera (BWC) devices in Security Center, learn about the symptoms, potential causes, and solutions to help you troubleshoot the issue.
Symptoms
Here are the common issues you might experience with a body-worn camera in Security Center. To help you solve the issue, click the error message or symptom that you are currently experiencing.
Things to consider
Configuration file errors for body-worn cameras
If you receive a One or more camera station configuration files are obsolete and must be regenerated for the Wearable Camera Manager role, one or more configuration files for body-worn camera stations contain errors.
Cause
One or more camera station configuration files are obsolete and must be regenerated.
The obsolete camera station configuration file is highlighted in red.
Solution 1
- From the Config Tool homepage, open the Video task, select the Wearable Camera Manager role, and click the Hardware tab.
- In the Camera stations section, select a camera station and click
Edit the item ().
- Select Generate new configuration file for this camera station
and click OK.
- Transfer the new .json configuration file to the camera station
or the Genetec Clearance™ Uploader.IMPORTANT: For security reasons, ensure that the original configuration file is deleted from its original location after it is successfully transferred. For example, C:\Users\username\AppData\Local\Temp\Genetec.
Solution 2
- From the Config Tool homepage, open the Video task, select the Wearable Camera Manager role, and click the Hardware tab.
- In the Camera stations section, click Regenerate all ().
- In the confirmation dialog box that opens, click Regenerate all.
- Transfer all new .json configuration files to the relevant camera
stations or the Genetec Clearance™ Uploader.IMPORTANT: For security reasons, ensure that the original configuration file is deleted from its original location after it is successfully transferred. For example, C:\Users\username\AppData\Local\Temp\Genetec.
Conversion warnings for body-worn cameras
Conversion warnings are displayed when the evidence files you have successfully uploaded were not converted to G64 and G64A formats.
Outside retention period
Cause: The wearable camera user, the Archiver role, or the Wearable Camera Manager role are set to keep files within a specified retention period, but the Genetec Clearance™ Uploader attempted to import a file outside that period.
- Archiver's Camera default settings page
- Wearable Camera Manager’s Recording settings page
- the wearable camera user's Recording page
Error converting resources
Cause: The downloaded file could not be converted because its format is not supported. The downloaded file was copied to the server location specified in the warning message.
Solution: Access the files manually at the location specified in the warning message.
Unable to copy locally
Cause: There was a conversion error and the downloaded file could not be copied to the server location specified in the warning message.
Solution: Check the local disk to ensure that you have enough storage space.
Failover cannot be configured on Archiver role for body-worn cameras
When failover is configured on the Archiver role that is used by a Wearable Camera Manager role, you receive an Archiver cannot have failover when using wearable cameras warning message.
Cause
Failover and redundant archiving are not supported on Archiver roles used for wearable (or body-worn) cameras.
Solution 1
- In the Config Tool homepage, open the Video task and select the Wearable Camera Manager role.
- Click the Properties tab and click Show advanced
settings.
- From the Default archiver list, select an Archiver that does not have failover configured.
- Select or enter the port that you require.
- Click Apply.IMPORTANT: You must generate new configuration files for your camera stations after changing these settings. See Configuration file errors for body-worn cameras.
Solution 2
- In Config Tool, open the Area
view task.
- Select a wearable camera user () and click the Properties tab.
- Under Advanced settings, select the Archiver and the Linked camera from their respective drop-down lists.
- Click Apply.
Body-worn camera port is already in use
The Wearable Camera Manager role is currently offline because the port is already in use. To resolve this issue, change the port specified in the Wearable Camera Manager role.
Cause
The Wearable Camera Manager role cannot open a connection on the specified port because the port is already in use.
Solution
- In Config Tool, open the System task and select the Wearable Camera Manager role.
- Change the specified port in the Wearable Camera Manager role
Properties tab.IMPORTANT: You must generate new configuration files for your camera stations after changing these settings. See Configuration file errors for body-worn cameras.
Archives report for body-worn camera is empty
The Archives report in Security Desk is empty. This occurs when the download or upload process times out.
Cause
- Download processing issues when copying from camera to download folder location.
- G64 file conversion processing issues.
- G64 file conversions in progress.
- Upload processing to Security Center archive times out.
Solution
- In the Genetec Clearance™ Uploader event logs, check that the files were downloaded.
- In Security Desk check that the
downloaded files are in the archives folder.
For example, C:\VideoArchives\Archiver\0000166\2018-02-26.
- If you see .G64 mentioned in the archives folder file path, wait
a few minutes.
The role needs time to convert the files so that the Archiver can read them.
- If the Archiver is still empty or unresponsive, do the following:
- In Config Tool, deactivate and activate the Wearable Camera Manager role.
- In Config Tool, deactivate and activate the Archiver role.
- In Security Desk generate the Archives report again.