[KBA-79060] Genetec™ Mobile does not start on iOS 14.2 when deployed using Mobile Device Management (MDM) - Genetec™ Mobile

series
Genetec™ Mobile
revised_modified
2020-11-20
TFSnum
2660831

[KBA-79060] Genetec™ Mobile does not start on iOS 14.2 when deployed using Mobile Device Management (MDM)

This article explains why Genetec™ Mobile does not start on iOS 14.2 when deployed using Mobile Device Management (MDM).

Symptoms

When the Genetec™ Mobile starts, a blank screen is displayed for 20 seconds and then the phone returns to the home screen.

Cause

There is a problem between Xamarin Forms and iOS 14.2 on Apple A12+ processors when installing applications using an MDM solution.

Impacted devices:

iPhone
  • XS and XS Max
  • XR
  • 11, 11 Pro, 11 Pro Max
  • SE (2nd generation)
  • 12, 12 Mini, 12 Pro, 12 Pro Max
iPad
  • iPad Air (2020)
  • iPad Mini (5th generation)
  • iPad Air (2019, 3rd generation)
  • iPad (2020, 8th generation)

Workaround

Do one of the following:
  1. Revert your iOS version to 14.1.
  2. Install the Genetec™ Mobile app from the app store instead of using MDM deployment.

Status

Microsoft and Apple are currently investigating the issue.