Upgrading the SDS Guardian plugin - SDS Guardian 3.1

SDS Guardian Plugin Guide 3.1

series
SDS Guardian 3.1
revised_modified
2019-03-19

If you already have Security Center and the SDS Guardian plugin, and you want to upgrade the plugin to version 3.x, you must upgrade Security Center and the plugin.

Before you begin

  • Learn what's new in the release.
  • Verify that the version of Security Center currently running in your system is compatible with the SDS Guardian plugin 3.1 . If the version of Security Center is not compatible, upgrade to a supported version.

What you should know

  • The plugin needs to be upgraded on all Security Center client and server computers.
  • It is not required to uninstall the plugin before upgrading to the new version.
  • When you install the latest plugin, the plugin database is automatically updated, and all entities and historical data is preserved.

Procedure

  1. On the computer you are upgrading, close all instances of Config Tool and Security Desk
  2. Download and install the SDS Guardian plugin as described in Downloading and installing the SDS Guardian plugin.
  3. After the plugin is upgraded, confirm that the upgrade was successful by doing the following:
    1. Log on to Config Tool, open the Plugins task.
    2. Select the SDS Guardian plugin role from the entity browser, and then click the Properties tab.
    3. Confirm that you see the new options for bookmarking and health alarms.
    4. Generate an SDS Events Report report and confirm that data from before the upgrade is still available.