[KBA-01022] “Invalid license” error in Security Center 5.x Server Admin - Security Center 5.2 - 5.7

series
Security Center 5.2 - 5.7
revised_modified
2015-04-09

[KBA-01022] “Invalid license” error in Security Center 5.x Server Admin

This article explains why you might receive an Invalid license error when trying to apply a license or modify hardware in Security Center 5.x.

Applies to: Security Center 5.2 - 5.7

Symptoms

When you try to apply a license or change system hardware in Security Center 5.x, you receive an Invalid license error message in Server Admin.

Cause

This issue is usually caused by hardware changes on the server where the license is installed, but can also occur due to other factors.

Workaround

To fix this issue, do the following:
CAUTION:
While performing this procedure, the system will not function until a valid license is activated and applied. If necessary, perform this procedure at a non-crucial time.
  1. Close the Server Admin.
  2. Navigate to the following folder:
    • 32-bit computer: C:\Program Files\Genetec Security Center 5.x\Configuration Files
    • 64-bit computer: C:\Program Files (x86)\Genetec Security Center 5.x\Configuration Files
  3. Copy the License.gconfig file to a safe location, and open the file using Notepad.
  4. Edit the file so that it only contains the following lines of code:
    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <Licensing License="" ValidationKey="" />
    </configuration>
  5. Reset your computer license and activate your Security Center license.
    For information about activating your license, see the document for your Security Center version:

If you encounter any issues during this procedure and need to restore the previous license, copy the backup License.gconfig file back into the Configuration files installation folder.

For additional information about this issue, contact the Genetec™ Technical Assistance Center.