[KBA-00108] How to test network connectivity for encoders in Omnicast™ - Omnicast™ 4.0 - 4.8

series
Omnicast™ 4.0 - 4.8
revised_modified
2011-11-17

[KBA-00108] How to test network connectivity for encoders in Omnicast™

This article explains how to test network connectivity between the Archiver server and an encoder in Omnicast™.

Symptoms

You are experiencing random issues with video encoders, such as:

  • Temporary video loss for live and recorded video
  • Units are constantly lost and re-detected.

Cause

There might be an issue with your network connection.

Workaround

Run a simple ping test that will log and inform you of any network connectivity issues, using the Pinglog.bat batch file.

  1. Download pinglog.bat.
  2. Open a Windows Command Prompt and type: pinglog [IP_ADDRESS] [# of Echo Requests]
    This command runs echo requests to the IP Address of the encoder you specified, and logs if network connection was lost. By default, 4 echo requests are sent, on average 1 echo per second.
    Example: If you want the ping test to run for 2 hours, then enter: pinglog 192.168.1.1 7200

    If you lost network connection to the encoder, a request timed out message is displayed. You can obtain the 10 last logs from c:\pinglog*.txt.