[KBA-78945] Incident Manager role not connecting to RabbitMQ - Genetec Mission Control™ 2.2 and later

series
Genetec Mission Control™ 2.2 and later
revised_modified
2018-08-15

[KBA-78945] Incident Manager role not connecting to RabbitMQ

This article explains why the Incident Manager role in Config Tool might go offline (turn red) and display the following error: “RabbitMQ connection failed”.

Symptoms

The Incident Manager role in Config Tool is red, and when you click the Diagnostic button, you receive the following error message:
RabbitMQ connection failed - <server IP address> Will retry in x seconds

Cause

The server that is running the Incident Manager role cannot connect to the RabbitMQ service running on port 5671 (default port), using an SSL connection.

Workaround

Try one or more of the following solutions:
  • In Windows, go to Control Panel > Services and make sure the RabbitMQ service has successfully started on the server where it is installed.
  • From the Incident Manager role configuration tabs in Config Tool, make sure you are using the correct username and password for the RabbitMQ connection. The username and password were created during the Genetec Mission Control™ installation.
  • Replace the RabbitMQ server name by the server’s IP address, or make sure the server name is clear (see the following image).

  • Make sure the server that is running the Incident Manager role can access the server running RabbitMQ on port 5671.
    Example: Open a command prompt and enter the command telnet <server IP address> 5671. If the servers are communicating properly, you will get a response.
  • Make sure that all firewall ports allow TCP connections both ways on port 5671, that is, to and from the Genetec Mission Control™ server and the RabbitMQ server.
  • From the RabbitMQ web console (https://localhost:15671), create a new RabbitMQ user that has admin rights, and make sure that the column Can access virtual hosts has a backslash (/) for all entries (see the image below).