[KBA-01205] “Cannot Fetch Active Directory Schema” Error when Trying to Import Fields from Active Directory - Security Center 5.2

series
Security Center 5.2
revised_modified
2015-02-05

[KBA-01205] “Cannot Fetch Active Directory Schema” Error when Trying to Import Fields from Active Directory

This article explains why Security Center users will get an error message when attempting to import fields from Active Directory in order to map them to custom fields.

Symptoms

When users want to import fields from Active Directory to map them to custom fields in Security Center, they receive the following error message:

Cannot fetch Active Directory Schema

Cause

In Security Center 5.2, the Active Directory role fetches the Active Directory schema by querying the domain controllers. The error above appears if the domain controllers are inaccessible or take too long to respond (there is a 3 minute timeout).

Workaround

None

Status

This issue is resolved in Security Center 5.2 SR3 CU4 and later.

After installing the above, go to the server where the Active Directory role is running and:

1. Edit the GeneralSettings.gconfig file (located by default in C:\Program Files\Genetec Security Center\ConfigurationFiles)

2. Add the following string under the <configuration> tag:

<activeDirectoryWFSynchronize domainController="Domain=DControl"/>

3. Replace the word “Domain” with the domain name and replace the word “DControl” with the domain controller hostname or IP address that should be used to fetch the Active Directory schema.

4. Save and close the file.