[KBA-78978] Incident monitoring task not working with Genetec Mission Control™ 2.11 GA and Sipelia™ 2.8 GA - Genetec Mission Control™ 2.11 GA | Sipelia™ 2.8 GA

series
Genetec Mission Control™ 2.11 GA | Sipelia™ 2.8 GA
revised_modified
2019-05-14

[KBA-78978] Incident monitoring task not working with Genetec Mission Control™ 2.11 GA and Sipelia™ 2.8 GA

This article explains why the Incident monitoring task is blank in Genetec Mission Control™ 2.11 GA if you also have Sipelia™ 2.8 GA installed on the client and server computers.

Symptoms

If you have Genetec Mission Control™ 2.11 GA and Sipelia™ 2.8 GA (build 2.8.1.2) is also installed on the client and server computers, the Incident monitoring task is blank.

Incidents are displayed in the notification tray, but when you double-click an incident you receive the following error: An unhandled exception occurred.

You also receive the following errors in the Windows Event Viewer logs:

Cause

Genetec Mission Control™ 2.11 GA uses RabbitMQ 3.7.10, but Sipelia™ 2.8 GA is not compatible with version 3.7.10. If you install or upgrade to Genetec Mission Control™ 2.11 GA and RabbitMQ is deployed on a computer that had an earlier version of RabbitMQ installed which was being used by Sipelia™ 2.8 GA, the issue with the Incident monitoring task occurs.

Workaround

Install Genetec Mission Control™ 2.11 GA Cumulative Hotfix 003 or later, and make sure you are using RabbitMQ in one of the following scenarios:
  • To use RabbitMQ 3.7.10 with Genetec Mission Control™ and RabbitMQ 3.6.9 with Sipelia™, you must host the RabbitMQ software on different servers.
  • To use the same RabbitMQ server for Genetec Mission Control™ and Sipelia™, you must use RabbitMQ 3.6.9.

Status

The workaround provided is supported with Genetec Mission Control™ 2.11 GA Cumulative Hotfix 003 and later. The workaround is longer required after you upgrade to Sipelia™ 2.8 SR1.