You insert a key in the programming station and in the Key Programmer application, you see the message: Invalid access rule. The key cannot be encoded.
Symptom
- A cardholder complains that the key does not work as expected.
- You insert the key in the programming station.
- The Key Programmer shows the message "Invalid access rule. The key cannot be encoded."
- In Config Tool, you open the plugin role's diagnostic window, and you see the message
"Incompatible access rule NameOfSchedule - A schedule can cover a
maximum of one time period per day. Impacted cardholders:
NameOfCardholder".
Cause
A Medeco XT key can only be assigned to a single Daily or Weekly schedule that is made up of a continuous block of time. If a key is configured to use an unsupported schedule, the programming station cannot update the key. Consequently, the key's cardholder can only use the key until its validation period expires.
Solution
- Change the schedule in the invalid access rule to either a continuous Daily or Weekly schedule.