Software requirements for Security Center 5.11 Web Client - Security Center 5.11

Security Center System Requirements Guide 5.11

Applies to
Security Center 5.11
Last updated
2022-10-25
Content type
System requirements
Language
English (United States)
Product
Security Center
Version
5.11

Before using Web Client, familiarize yourself with the operating systems and browsers that are supported with Web Client.

The software requirements for Security Center 5.11 Web Client are the following:
Operating system Supported Browsers

Microsoft® Windows 10 Professional and Enterprise (32-bit or 64-bit)

Microsoft® Windows 8.1 Professional and Enterprise (32-bit or 64-bit)

  • Microsoft Internet Explorer 11 or higher
  • Microsoft Edge for Windows 10
  • Google Chrome latest version
  • Mozilla Firefox latest version

Microsoft® Windows Server® 2012 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2016 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2017 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2019 Standard Edition and R2 (32-bit or 64-bit)

Microsoft® Windows Server® 2022 Standard Edition and R2 (32-bit or 64-bit)

  • Microsoft Internet Explorer 11 or higher
  • Google Chrome latest version
  • Mozilla Firefox latest version
Mac OS X 10.9.1 Apple Safari (desktop version)
NOTE: The Genetec™ Web App is currently in preview. System requirements specifically for the Genetec™ Web App will be added when benchmark testing is completed and the full version is released.
NOTE: If you are not seeing high-quality (H.264) video in your Firefox browser, make sure that H.264/avc3 on the media source extension is enabled.
NOTE: Apple Safari for iOS and Google Chrome for Android devices are not supported by Security Center 5.11 Web Client. To access Security Center videos and data from your smartphone, you should use Genetec™ Mobile.