Key Systems Security Asset Manager plugin missing from Security Desk and Config Tool - Key Systems Security Asset Manager 3.0.0

Key Systems Security Asset Manager Plugin Guide 3.0.0

Applies to
Key Systems Security Asset Manager 3.0.0
Last updated
2024-03-01
Content type
Guides > Plugin and extension guides
Language
English
Product
Key Systems Security Asset Manager
Version
3.0

If custom events and alarms are missing from the Key Systems activities and Key Systems assets tasks, or the plugin-specific Properties page, then the plugin is not installed on your local machine.

Symptoms

One, or a combination of the following:

  • In Config Tool, you see the plugin in the Plugins task, and you can add a new plugin role, but the role is missing the Properties tab.
  • In Config Tool or Security Desk, you do not see the Key Systems activities and Key Systems assets tasks.
  • Parts of the user interface that are related to the plugin are not available in Config Tool or Security Desk.

Causes

One, or a combination, of the following:

  • The plugin is not installed on the local computer.
  • The license (certificate) is invalid.

Solutions

One, or a combination, of the following:

  • Confirm that the plugin has been installed, and the role has been created and configured correctly:
    1. Open Config Tool or Security Desk on your local machine.
    2. From the homepage, click About > Installed components.
    3. Look in the list for entries that begin with Genetec.Plugins.

    If the plugin is not listed, it must be installed on your local computer.

  • Confirm that your system has a license (certificate) for the plugin:
    1. Open Config Tool or Security Desk.
    2. From the homepage, click About > Certificates.
    3. From the list of certificates, find the plugin and make sure that access permissions are set to Unlimited.

    If the license must be updated, contact your Genetec™ representative.